5 posts / 0 new
Last post
sridharar
Offline
Joined: 03/18/2017 - 16:39
How to get MIDI Input to Work

Sorry if I am posting this in the wrong category...but I am assuming that there is some issue here (and not an operation error on my part)

I am on Windows 10 and have a Korg PA600 keyboard connected to my laptop via USB and Korg ISB Driver.

I am using Caustic 3.2 version.

KORG PA600 works fine with my Midi-OX, Ableton Lite and my Visual C# personal code.

But I have so far I have no luck to get Caustic to see/record my PA600 inputs.

Caustic does show Pa600 Keyboard in the  Options->Midi-> box.

I have also selected "Midi controls on-screen instruments"

I do see a small icon a 5-pin MIDI port in the bottom area to the left of pattern/song box.

Any tips would be appreciated. 

 

 

 

sridharar
Offline
Joined: 03/18/2017 - 16:39
More..

More..

I uninstalled the Windows 10 KORG USB Driver. 

I connected My Alexis Keytar via USB Midi.

Caustic works fine and captures all the inputs from Alesis.

Confirmed that my operating procedures were correct.

Now I connected my Korg PA600.

This time Caustic will play one note and then CRASH.

So, with [whatever] the generic USB Midi Driver that is in the mix - CAUSTIC CRASHES.

With Korg USB Midi driver - there is no CRASH, but midi inputs are not processed.

sridharar
Offline
Joined: 03/18/2017 - 16:39
Further narrowed down..

Further narrowed down..

I reinstalled the KORG USB Driver.

I started a new song.

Used PCMSynth. Loaded a preset.

Went to piano roll. Selected "pattern"

MIDI icon is lit. 

I hit record button.

All keys I play on my midi board are received and played by Caustic.

Now I enter the Play button to actually record. 

Play a key on my keyboard.

BOOM. CAUSTIC RASHES.

Spinneysc
Online
Joined: 09/28/2012 - 13:22
Well, I can't comment on the

Well, I can't comment on the crash, but, just as a suggestion, you might confirm the midi out channel mapping on the PA600 (MIDI: MIDI Out Channels). By default it looks like the lower part of the keyboard (below the split) goes on channel 1 and the upper part of the keyboard is broadcast on channels 2 3 and 4. So, if your PA600 is configured this way, you could try putting Caustic into "One MIDI channel per instrument [1..14]" and put subsynth machines for example into slots 1 2 3 and 4 and see if you get any noise out of Caustic when you press keys.

 

sridharar
Offline
Joined: 03/18/2017 - 16:39
Thanks Spinneyc for your

Thanks Spinneyc for your suggestion. 

My thoughts are..

I am quite comfortable with Midi Stuff in general and confident of the settings on the PA600 keyboard. 

I have setup MIDI out on my keyboard to send only Ch 1,2,3 signals which are all on the
right side of the split (Upper 1, 2, and 3).

I am also muting ch 2 and 3 and sending midi messages only on Channel 1. 

I have also confirmed this via Midi OX and Ableton. 

As I mentioned, Caustic actually processes the Midi inputs and plays them on the selected Preset fine - when Record button is on and Play button is off.

But, as soon as I hit the Play button and press a key on my keyboard it crashes. 

So I think it is something to do with Caustic+Record+Play+KorgDriver combination. 

BTW, I have also configured PA600 to send Midi Out Only. It does not receive Midi In. 
So there are no possibilities of messages looping, flooding the channel and leading to crash.