18 posts / 0 new
Last post
spyroks
spyroks's picture
Offline
Joined: 06/09/2012 - 10:19
3.2b5 doesn't record audio

Device Samsung S3 with kitkat 4.4.2. Installed 3.2b5, loaded a PCMSynth, hit the record button. Nothing happens, the record button becomes a shade darker but the cursor doesn't move, nothing gets recorded. I loaded 3.1 from the Play store and recording works. Any ideas?

Jason
Jason's picture
Offline
Joined: 03/23/2012 - 21:32
Have you cold-booted your

Have you cold-booted your phone and tried it again from scratch?   

ColdBoot, Launch new session of Caustic, load up PCMSynth and try Record again?

Also, does the S3 no longer update its OS?   at least to 5.0?

derrtiblu
derrtiblu's picture
Offline
Joined: 03/08/2014 - 23:00
his device is having a out of

his device is having a out of date service issue.

and samsung may not have giving up such of a factory update two dat model phone.

((( the company is more focused on newer model flag ship phones cause they know they phones will be rooted )))

and it sounds like his device his not rooted.

sooo the option of customizing a up two date os is what alot of red tape is. i think mr. spyroks does not have time for.

and it being a contract phone..... not advisable two do @ mr. jason.

Jason
Jason's picture
Offline
Joined: 03/23/2012 - 21:32
Derrti, it may have nothing

Derrti, it may have nothing to do with his problem, yet  we are trying to get clues to his recording issue.   The S3 does do good quality recordings.  My Tab2 fails to record half of the times, but I find if I clear Caustic out of Open Tasks, and start a new session from scratch, I am able to record again (running 4.1.x on it, and no longer supported by Google)

I didn't suggest rooting his phone either.

Spyrocks, have you tried my idea yet?

spyroks
spyroks's picture
Offline
Joined: 06/09/2012 - 10:19
I have a custom Rom, Wicked

I have a custom Rom, Wicked S5 Experience 4.4.2, rooted, with Philz recovery, so the S3 flies!  Soon I will have installed marshmallow (waiting for the developers to deliver), meaning much lower latency among other goodies. Anyway, so I reinstalled 3.2b5 and rebooted into recovery, cleared cache and dalvik but still the PCMSynth recording doesn't work, same results as in my original post. As I said before, in 3.1 the recording works well.

derrtiblu
derrtiblu's picture
Offline
Joined: 03/08/2014 - 23:00
hmmm. idk but let me look for

ok i took the problem this time around as u was discussing in the record in just in at the top of the machine.how u can hit record. but.....

in the section where u load sample. and record. say your voice......

it does go dark. in 3.2.4. and it does not record at all. sooo its a previous bug dat does repro100% of the time.

good look @ spyrok. u was right.

i am checkin' all the other wav editors now.
repro 100% time all wav editors. beatbox,pcmsynth, vocoder. is there any other wav editors??

demonshredder
Offline
Joined: 01/15/2016 - 01:04
i experienced this as well,

i experienced this as well,with 3.2.4 ,  i would record but no audio would show up.  cleared tasks and success.  it was with the wav editor, when using the vocodor.   although, i'm not sure what it means to record audio with the pcmsynth, unless you mean the notes and automations.    am i missing something?      Jason, i agree, that galaxy does (surprisingly) great recordings.

Jason
Jason's picture
Offline
Joined: 03/23/2012 - 21:32
I still use my old Galaxy S

I still use my old Galaxy S for audio recordings sometimes....

demonshredder
Offline
Joined: 01/15/2016 - 01:04
i just did a long press on

i just did a long press on the level button for pcmsynth. waveditor opened up.aaaaaaand i remembered accessing it before just like this

pquenin
pquenin's picture
Offline
Joined: 07/30/2013 - 17:47
Have to check this... I have

Have to check this... I have tried yesterday with the standalone WAV editor and beta 5 and recording was fine, but have not tried in the Beatbox, PCM synth and Vocoder...

Rej - Dev
Rej - Dev's picture
Offline
Joined: 12/18/2011 - 15:52
spyroks, it's possible your

spyroks, it's possible your ROM doesn't support stereo recording correctly. I tried a Cyanogen ROM on my wife's S3 and got the same thing. I was going crazy trying to figure out what I was doing wrong but then realized the phone was saying "all good, yes I can record in stereo" and then failing when I tried to record. There's not much I can do in that case, if the phone says it can do it, it should otherwise that's a bug.

Caustic 3.1 only recorded in mono and I guess the S3 + ROM doesn't have any bugs with that setup. In fact, if it only answered "no I can't record stereo", then Caustic would revert to mono but instead it says it can record in stereo...

paulovski
paulovski's picture
Offline
Joined: 09/19/2012 - 06:13
Clutching at straws. Would

Clutching at straws. Would the mono Vocoder work here?

pquenin
pquenin's picture
Offline
Joined: 07/30/2013 - 17:47
Maybe add a button "record in

Maybe add a button "record in mono" ?

Jason
Jason's picture
Offline
Joined: 03/23/2012 - 21:32
^^^^^ agreed.......

^^^^^ agreed.......

spyroks
spyroks's picture
Offline
Joined: 06/09/2012 - 10:19
Rej, you are right. The

Rej, you are right. The Sprint S3 (US variant) doesn't record in stereo (even in video mode), no matter what ROM I use.  I wish there was a way to record in mono, my tablet, a Samsung Note 10.1 doesn't record in stereo either...so anything newer than 3.1 won't allow for recording at all...sad

@pquenin   @ Jason  I agree with you, a "record in mono" button would work for many people that have devices that don't record in stereo (most tablets?)....

 

 

pquenin
pquenin's picture
Offline
Joined: 07/30/2013 - 17:47
I have a Samsung Galaxy Tab 3

I have a Samsung Galaxy Tab 3 8'' that record in stereo. I have seen that in the WAV editor you don't have the little arrows to snap to zero crossing points if the audio is in stereo...

spyroks
spyroks's picture
Offline
Joined: 06/09/2012 - 10:19
@ pquenin  It seems that your

@ pquenin  It seems that your tablet has only one microphone but correct me if I'm wrong..

If anyone succeeded with  recording in mono or stereo on the 3.2b4 please let us know...

Update: On Windows it records fine through the mono mic and assigns the same signal on both channels.

pquenin
pquenin's picture
Offline
Joined: 07/30/2013 - 17:47
Yes, it seems that the tablet

Yes, it seems that the tablet has only one microphone, but when I record in Caustic, it creates a stereo file...